Numerology Store    Download  Video    Forum


Go Back   Five12.net -- Online Forum for the Numerology Music Sequencer > Techniques > Tips & Tricks

Reply
 
Thread Tools Display Modes
  #1  
Old 06-17-2009, 10:23 PM
jim jim is offline
Administrator
 
Join Date: Nov 2008
Location: Albuquerque, NM
Posts: 4,555
Default Using Numerology with Reaper in ReWire mode

Reaper is a DAW app, you can get it here: http://www.reaper.fm
Although Reaper's ReWire implementation is a bit unusual, it isn't too hard to set it up to work with Numerology:

- Start Reaper
- Create a new track (cmd-T), or choose an existing one.
- Click the "fx" button on the track, this brings up an 'Add FX' dialog, click "ReWire", then "ReWire: Numerology".

- Now you can start Numerology. If you start it before setting up the FX stuff, Numerology will open standalone.

To pick an input channel other than 1&2, click the "fx" button again, and use the "Audio from ReWire" to set the assignment.

Cheers,
Jim

Last edited by jim; 06-17-2009 at 10:25 PM.
Reply With Quote
  #2  
Old 12-25-2010, 01:48 AM
riffkillsman riffkillsman is offline
Member
 
Join Date: Dec 2010
Posts: 32
Default reaper and numerology

i tried this and it worked! BUT i cant listen back to the audio i recorded? and it clearly shows audio was in fact recorded? ma
i am using numerology to sequence a nord micro modular. so im using a hardware synth. is the above only instructions for a vst?
maybe this would be best posted on the reaper forum?
Reply With Quote
  #3  
Old 12-25-2010, 03:22 PM
riffkillsman riffkillsman is offline
Member
 
Join Date: Dec 2010
Posts: 32
Smile

ok so i solved my problem, i guess once you have tracked using reaper, to listen to play back of what you have recorded you have to disable the rewire(of numerology) by disabling the fx. i had this same issue with protools.
is there another way to get around this?
Reply With Quote
  #4  
Old 12-26-2010, 09:58 AM
jim jim is offline
Administrator
 
Join Date: Nov 2008
Location: Albuquerque, NM
Posts: 4,555
Default

This all sounds rather odd. I don't know Reaper all that well so I'll do some testing and post some tips later this week.

Best,
Jim
Reply With Quote
  #5  
Old 12-27-2010, 09:42 PM
riffkillsman riffkillsman is offline
Member
 
Join Date: Dec 2010
Posts: 32
Default

that would be great! i am still having trouble with it. i get crashes a lot more frequently than before and sometimes playback will work and other times not?
it seems to overload the cpu. maybe i need to change some things around on that end. i was using an m audio interface that is usb powered. i have since switched to a presonus firepod, that is powered via a wall wart, but im still getting the same results. lately i can record one track ok, but when i arm and start recording a second track both reaper and numerology will freeze and i will have to force quit them to start over, loosing all the work i had done.
Reply With Quote
  #6  
Old 12-28-2010, 10:16 AM
jim jim is offline
Administrator
 
Join Date: Nov 2008
Location: Albuquerque, NM
Posts: 4,555
Default

Quote:
Originally Posted by riffkillsman View Post
that would be great! i am still having trouble with it. i get crashes a lot more frequently than before and sometimes playback will work and other times not?
it seems to overload the cpu. maybe i need to change some things around on that end. i was using an m audio interface that is usb powered. i have since switched to a presonus firepod, that is powered via a wall wart, but im still getting the same results. lately i can record one track ok, but when i arm and start recording a second track both reaper and numerology will freeze and i will have to force quit them to start over, loosing all the work i had done.
Email me your most recent 4-5 crash logs, both for Reaper and Numerology: jim at five12 dot com. They will be in :
<your home dir>/Library/Logs/CrashReporter
or (if you are using 10.6.4 or later)
<your home dir>/Library/Logs/Diagnostic Reports

Thanks,
Jim
Reply With Quote
  #7  
Old 12-31-2010, 04:53 AM
nk_e nk_e is offline
Junior Member
 
Join Date: Dec 2010
Posts: 9
Default

FWIW, I'm trying it with the v4 alpha and it crashes immediately. I know, alpha and all, but I thought I'd give you a heads up.

It's also crashing with StudioOne Pro btw. By that I mean, once you insert the "rewire track" into S1Pro and start Numerology3, S1Pro immediately crashes when Numerology3 completes its launch.

Here's part of the crash report. (Not trying to hijack the thread, just figure the problem maybe similar.)


Process: studioapp [382]
Path: /Applications/Studio One.app/Contents/MacOS/studioapp
Identifier: com.presonus.studioone
Version: 1.6.2 Build 13889 (1000)
Code Type: X86 (Native)
Parent Process: launchd [200]

Date/Time: 2010-12-31 08:34:47.571 -0500
OS Version: Mac OS X 10.6.5 (10H574)
Report Version: 6

Interval Since Last Report: 317305 sec
Crashes Since Last Report: 7
Per-App Interval Since Last Report: 15288 sec
Per-App Crashes Since Last Report: 4
Anonymous UUID: 8D59156D-7BA4-40FB-BD00-EC9D71057E3A

Exception Type: EXC_BAD_ACCESS (SIGBUS)
Exception Codes: KERN_PROTECTION_FAILURE at 0x0000000000000000
Crashed Thread: 6

Thread 0: Dispatch queue: com.apple.main-thread
0 libSystem.B.dylib 0x924740fa mach_msg_trap + 10
1 libSystem.B.dylib 0x92474867 mach_msg + 68
2 com.apple.CoreFoundation 0x96ebf37f __CFRunLoopRun + 2079
3 com.apple.CoreFoundation 0x96ebe464 CFRunLoopRunSpecific + 452
4 com.apple.CoreFoundation 0x96ebe291 CFRunLoopRunInMode + 97
5 com.apple.HIToolbox 0x90740f9c RunCurrentEventLoopInMode + 392
6 com.apple.HIToolbox 0x90740d51 ReceiveNextEventCommon + 354
7 com.apple.HIToolbox 0x90740bd6 BlockUntilNextEventMatchingListInMode + 81
8 com.apple.AppKit 0x914c078d _DPSNextEvent + 847
9 com.apple.AppKit 0x914bffce -[NSApplication nextEventMatchingMask:untilDate:inMode:dequeue:] + 156
10 com.apple.AppKit 0x91482247 -[NSApplication run] + 821
11 com.presonus.cclgui 0x00c19436 GetWindowManager + 74852
12 com.presonus.cclgui 0x00c1936b GetWindowManager + 74649
13 com.presonus.studioone 0x00037c9b GetCurrentModuleRef + 209
14 com.presonus.studioone 0x000a3070 GetCurrentModuleRef + 439462
15 com.presonus.studioone 0x00037b9e start + 54

Thread 1: Dispatch queue: com.apple.libdispatch-manager
0 libSystem.B.dylib 0x9249a982 kevent + 10
1 libSystem.B.dylib 0x9249b09c _dispatch_mgr_invoke + 215
2 libSystem.B.dylib 0x9249a559 _dispatch_queue_invoke + 163
3 libSystem.B.dylib 0x9249a2fe _dispatch_worker_thread2 + 240
4 libSystem.B.dylib 0x92499d81 _pthread_wqthread + 390
5 libSystem.B.dylib 0x92499bc6 start_wqthread + 30

Thread 2:
0 libSystem.B.dylib 0x924a20a6 __semwait_signal + 10
1 libSystem.B.dylib 0x924cdee5 nanosleep$UNIX2003 + 188
2 libSystem.B.dylib 0x924cde23 usleep$UNIX2003 + 61
3 com.presonus.cclsystem 0x00f4d181 ThreadSleep + 21
4 com.presonus.cclsystem 0x00f14f0c GetMediaThreadService + 1644
5 com.presonus.cclsystem 0x00f14afd GetMediaThreadService + 605
6 com.presonus.cclsystem 0x00f06ee3 GetThreadWithIdentifier + 506
7 com.presonus.cclsystem 0x00f4da49 ThreadSleep + 2269
8 libSystem.B.dylib 0x924a185d _pthread_start + 345
9 libSystem.B.dylib 0x924a16e2 thread_start + 34

Thread 3:
0 libSystem.B.dylib 0x924a20a6 __semwait_signal + 10
1 libSystem.B.dylib 0x924cdee5 nanosleep$UNIX2003 + 188
2 libSystem.B.dylib 0x924cde23 usleep$UNIX2003 + 61
3 com.presonus.cclsystem 0x00f4d181 ThreadSleep + 21
4 com.presonus.cclsystem 0x00f14f0c GetMediaThreadService + 1644
5 com.presonus.cclsystem 0x00f14afd GetMediaThreadService + 605
6 com.presonus.cclsystem 0x00f06ee3 GetThreadWithIdentifier + 506
7 com.presonus.cclsystem 0x00f4da49 ThreadSleep + 2269
8 libSystem.B.dylib 0x924a185d _pthread_start + 345
9 libSystem.B.dylib 0x924a16e2 thread_start + 34

Thread 4:
0 libSystem.B.dylib 0x924740fa mach_msg_trap + 10
1 libSystem.B.dylib 0x92474867 mach_msg + 68
2 ....audio_hijack_server.hermes 0x013db3cf ah_serv_loop + 161
3 libSystem.B.dylib 0x924a185d _pthread_start + 345
4 libSystem.B.dylib 0x924a16e2 thread_start + 34

Thread 5:
0 libSystem.B.dylib 0x924740fa mach_msg_trap + 10
1 libSystem.B.dylib 0x92474867 mach_msg + 68
2 com.apple.CoreFoundation 0x96ebf37f __CFRunLoopRun + 2079
3 com.apple.CoreFoundation 0x96ebe464 CFRunLoopRunSpecific + 452
4 com.apple.CoreFoundation 0x96ec43a4 CFRunLoopRun + 84
5 com.apple.DVCPROHDMuxer 0x1d18b98f AVS:estroyAVCDeviceController(AVS::AVCDeviceCont roller*) + 317
6 libSystem.B.dylib 0x924a185d _pthread_start + 345
7 libSystem.B.dylib 0x924a16e2 thread_start + 34

Thread 6 Crashed:
0 com.five12.N3ReWireDriver 0x1fb1608d five12_base::BinaryObjectInputStream::lookupObject (unsigned long) + 129
1 com.five12.N3ReWireDriver 0x1fb1600a five12_base::BinaryObjectInputStream::readRefToObj ect() + 56
2 com.five12.N3ReWireDriver 0x1fb8cb07 five12_event::PropertyCommand::initFromStream(five 12_base::ObjectInputStream*, unsigned long) + 117
3 com.five12.N3ReWireDriver 0x1fb8c975 five12_event::PropertyCommand::newFromStream(five1 2_base::MemoryManager*, five12_base::ObjectInputStream*, unsigned long) + 97
4 com.five12.N3ReWireDriver 0x1fb162d0 five12_base::BinaryObjectInputStream::readObject() + 458
5 com.five12.N3ReWireDriver 0x1fb03d60 RWDEFIdle + 432
6 ...opellerheads.rewire.library 0x1dab6fa9 RWPUnregisterDeviceImp + 3647
7 ...opellerheads.rewire.library 0x1dab82e2 RWPUnregisterDeviceImp + 8568
8 ...opellerheads.rewire.library 0x1dab8880 RWPUnregisterDeviceImp + 10006
9 ...opellerheads.rewire.library 0x1dacd10e RWPUnregisterDeviceImp + 94116
10 libSystem.B.dylib 0x924a185d _pthread_start + 345
11 libSystem.B.dylib 0x924a16e2 thread_start + 34

>snip<

Thread 6 crashed with X86 Thread State (32-bit):
eax: 0x00000000 ebx: 0x1fb16018 ecx: 0x00000001 edx: 0x00000000
edi: 0x03cd60b0 esi: 0x2fa57970 ebp: 0xb0102cb8 esp: 0xb0102c80
ss: 0x0000001f efl: 0x00010286 eip: 0x1fb1608d cs: 0x00000017
ds: 0x0000001f es: 0x0000001f fs: 0x0000001f gs: 0x00000037
cr2: 0x00000000

>snip<

Model: MacPro2,1, BootROM MP21.007F.B06, 8 processors, Quad-Core Intel Xeon, 3 GHz, 9 GB, SMC 1.15f3
Graphics: ATI Radeon X1900 XT, ATY,RadeonX1900, PCIe, 512 MB
Memory Module: global_name
Bluetooth: Version 2.3.8f7, 2 service, 19 devices, 1 incoming serial ports
Network Service: Built-in Ethernet 1, Ethernet, en0
PCI Card: pci-bridge, sppci_pci2pcibridge, Slot-4
PCI Card: pci1033,e7, sppci_ieee1394openhci, Slot-4@4,1,0
PCI Card: pci1033,e0, USB Enhanced Host Controller, Slot-4@4,0,1
PCI Card: pci1033,35, sppci_usbopenhost, Slot-4@4,0,0
PCI Card: pci-bridge, sppci_pci2pcibridge, Slot-3
PCI Card: pci1033,e0, USB Enhanced Host Controller, Slot-3@6,0,2
PCI Card: pci1033,35, sppci_usbopenhost, Slot-3@6,0,1
PCI Card: pci1033,35, sppci_usbopenhost, Slot-3@6,0,0
PCI Card: ATY,RadeonX1900, Display, Slot-1
PCI Card: pci-bridge, sppci_pci2pcibridge, Slot-2
PCI Card: Universal Audio UAD-1e Expert Pak, sppci_othermultimedia, Slot-2@17,0,0
Serial ATA Device: WDC WD5000AAKS-41TMA0, 465.76 GB
Serial ATA Device: ST3500630AS, 465.76 GB
Serial ATA Device: WDC WD10EACS-00ZJB0, 931.51 GB
Serial ATA Device: ST31500341AS, 1.36 TB
Parallel ATA Device: TSSTcorp CDDVDW SH-S222L
USB Device: Hub, 0x0424 (SMSC), 0x2514, 0xfd500000
USB Device: Hub, 0x0409 (NEC Corporation), 0x005a, 0xfd520000
USB Device: iLok, 0x088e, 0x5036, 0xfd522000
USB Device: CodeMeter-Stick, 0x064f (WIBU-Systems AG), 0x03e9, 0xfd524000
USB Device: Hub, 0x0424 (SMSC), 0x2640, 0xfd510000
USB Device: ProtectExecuter, 0x0819, 0x0101, 0xfd513000
USB Device: FaderPort, 0x194f, 0x0201, 0xfd512000
USB Device: Ultra Fast Media Reader, 0x0424 (SMSC), 0x4060, 0xfd511000
USB Device: Hub, 0x0424 (SMSC), 0x2514, 0xfd300000
USB Device: Maschine Controller, 0x17cc, 0x0808, 0xfd330000
USB Device: Hub, 0x0424 (SMSC), 0x2640, 0xfd310000
USB Device: Ultra Fast Media Reader, 0x0424 (SMSC), 0x4060, 0xfd311000
USB Device: Kore Controller, 0x17cc, 0x4711, 0x40300000
USB Device: Express 128, 0x07fd, 0x0001, 0x3d200000
USB Device: Bluetooth USB Host Controller, 0x05ac (Apple Inc.), 0x8206, 0x5d200000
USB Device: Axiom Pro 49, 0x0763 (M-Audio), 0x2023, 0xff100000
FireWire Device: built-in_hub, Up to 800 Mb/sec
FireWire Device: Vendor 0x1F2 Device 0x101800, 0x1F2, Up to 400 Mb/sec
__________________
8 core Mac 3ghz | Googobs of RAM | OS 10.6.5 | NumPro3
Please checkout my blog or send me a track at SoundCloud. Cheers!

Last edited by nk_e; 12-31-2010 at 05:19 AM.
Reply With Quote
  #8  
Old 01-01-2011, 12:50 PM
jim jim is offline
Administrator
 
Join Date: Nov 2008
Location: Albuquerque, NM
Posts: 4,555
Default

I found an issue just yesterday where there is a conflict between the N2.3 rewire driver and the N3 rewire driver. For now, you should manually go in and delete any older drivers. Look in:
/Library/Application Support/Propellerhead Software/ReWire
and delete anything with "Numerology" in the name. Then go and do a full install of build 26:

http://www.five12.com/Numerology3Pro-Build26.dmg

I should have more news later today...

Cheers,
Jim
Reply With Quote
  #9  
Old 01-02-2011, 03:55 AM
nk_e nk_e is offline
Junior Member
 
Join Date: Dec 2010
Posts: 9
Default

Yes!!! That seems to have done the trick! StudioOnePro also behaves now!

Fantastic. Thank you.

BTW getting this working deprecates another request I had. In another thread I had asked for parameter automation capture within Numerology. Until that happens, I can run my efx in StudioOne or Reaper and capture/edit the automation in there. Works fine for now.

Thanks again.
__________________
8 core Mac 3ghz | Googobs of RAM | OS 10.6.5 | NumPro3
Please checkout my blog or send me a track at SoundCloud. Cheers!
Reply With Quote
  #10  
Old 01-02-2011, 12:25 PM
gwok gwok is offline
Junior Member
 
Join Date: Jul 2010
Posts: 27
Default

Hey Jim,

You may remember I've had issues with Reaper/Numerology and Rewire

though I just did a fresh install - osx 10.6.4, and am running N3build 26 on Reaper 3.74

so I'm gonna give rewire another shot and we'll see how it goes with a nice fresh OS and most recent builds of all apps

I'll keep you posted and IF there's crashes sent you the logs, though lets hope for not!

thanks for all the great work

g
Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -6. The time now is 03:46 PM.


Powered by vBulletin® Version 3.8.1
Copyright ©2000 - 2019, Jelsoft Enterprises Ltd.