Numerology Store    Download  Video    Forum


Go Back   Five12.net -- Online Forum for the Numerology Music Sequencer > Numerology > General Questions

Reply
 
Thread Tools Display Modes
  #1  
Old 02-09-2017, 04:09 PM
adgangfolmer adgangfolmer is offline
Junior Member
 
Join Date: Feb 2017
Posts: 3
Default Prevent App Nap with N 4.2 on Yosemite

Hi

I can see, that this has been discussed a bit before, but I never found a solution.

When I run N 4.2 as ReWire Slave with Ableton, I often have problems with Numerology and my launchpad freezing because it goes into App Nap mode. This really destroying my work flow (I'm using it in my live performance). Is there a work around to avoid App Nap, because I can't disable it the usual way.

I'm on Yosemite btw.

Thanks
- Stig
Reply With Quote
  #2  
Old 02-10-2017, 01:55 PM
vestibul vestibul is offline
Junior Member
 
Join Date: Oct 2015
Posts: 23
Default

would this help? http://osxdaily.com/2014/05/13/disab...-nap-mac-os-x/
Reply With Quote
  #3  
Old 02-10-2017, 04:39 PM
jim jim is offline
Administrator
 
Join Date: Nov 2008
Location: Albuquerque, NM
Posts: 4,177
Default

Double-check that you have the latest build installed (170). There's code that should prevent app nap in there already, but I am not certain when it was added.

Jim
Reply With Quote
  #4  
Old 02-11-2017, 12:38 AM
adgangfolmer adgangfolmer is offline
Junior Member
 
Join Date: Feb 2017
Posts: 3
Default

I do have the latest build (170), but I am still having problems.

Last edited by adgangfolmer; 02-11-2017 at 12:42 AM.
Reply With Quote
  #5  
Old 02-11-2017, 12:39 AM
adgangfolmer adgangfolmer is offline
Junior Member
 
Join Date: Feb 2017
Posts: 3
Default

I have already tried that work around, but it doesn't seem to solve the problem.

Edit: The Terminal work around actually does seem to work. It's just me, who isn't too experienced with Terminal, so I had forgotten to hit return after I entered the command... doh!
So it seems that there is a solution, but the code in N4 doesn't seem to work, if App Nap is supposed to be disabled as default.

Thanks for the help

Last edited by adgangfolmer; 02-11-2017 at 01:09 AM.
Reply With Quote
  #6  
Old 02-12-2017, 06:42 PM
jim jim is offline
Administrator
 
Join Date: Nov 2008
Location: Albuquerque, NM
Posts: 4,177
Default

Try build 171: http://www.five12.net/showthread.php?p=15946#post15946

... There's a little code trick that is commonly used to avoid app nap and I think my impl of it needed a little tweaking..

Jim
Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -6. The time now is 09:27 PM.


Powered by vBulletin® Version 3.8.1
Copyright ©2000 - 2017, Jelsoft Enterprises Ltd.