Numerology Store    Download  Video    Forum


Go Back   Five12.net -- Online Forum for the Numerology Music Sequencer > Numerology > General Questions

Reply
 
Thread Tools Display Modes
  #21  
Old 01-05-2019, 08:26 AM
Aramis Aramis is offline
Senior Member
 
Join Date: Aug 2013
Location: Quebec City
Posts: 280
Default

Quote:
Originally Posted by PLaine View Post
Hi and Happy New Year to everyone!

I think I can go ahead with High Sierra, but I have had couple of crashes and clearly more than with El Capitan. There's this strange thing with Numerology which is same if you start with new computer:

If I update my mac OS (or start with new computer) my old Numerology files won't play correctly and very often they crash too. I can see all the correct MIDI destinations (I use iConnect MIO4 between my Mac and Hardware synths) but what I need to do is to choose every one them again and save project(s). This is same with midi clock destinations.

Now with High Sierra it seems to me that if I re-adjust all those MIDI destinations Numerology plays quite reliably but time will tell...

Is there something what can be made different? Of course, I can edit my files once again, fortunately there ain't that many

thanks,
P
Interesting, I hope Jim is reading this. I am slowly installing my audio software ( synths and and tools ) to a new Mac Mini 2018. My preferred DAW ( DigitalPerformer 9.52) , Native Instrument (Komplete 11 Ultimate) and Spectrasonics ( Omnisphere ) work fine in MOJAVE (Mac Mini 2018 ) but Numerology Pro 179 do not . ;-(
Reply With Quote
  #22  
Old 01-11-2019, 12:30 PM
PLaine PLaine is offline
Member
 
Join Date: May 2013
Location: Finland
Posts: 98
Default

In general it seems to me that Numerology somehow messes up with MIDI timing more than before. I use N with external hardware synths via iConnect Mio4. Many of my projects now start with a second or two midi mess and then it finds the correct time or crash the whole app...
Reply With Quote
  #23  
Old 01-12-2019, 09:59 PM
jim jim is offline
Administrator
 
Join Date: Nov 2008
Location: Albuquerque, NM
Posts: 4,458
Default

Quote:
Originally Posted by PLaine View Post
In general it seems to me that Numerology somehow messes up with MIDI timing more than before. I use N with external hardware synths via iConnect Mio4. Many of my projects now start with a second or two midi mess and then it finds the correct time or crash the whole app...
That sounds like an issue w/ MIDI Timestamping in OS X. Can you use the MIDIMonitor to run a trace on output from Numerology to the Mio4?

Jim
Reply With Quote
  #24  
Old 01-12-2019, 10:01 PM
jim jim is offline
Administrator
 
Join Date: Nov 2008
Location: Albuquerque, NM
Posts: 4,458
Default

Quote:
Originally Posted by Aramis View Post
Interesting, I hope Jim is reading this. I am slowly installing my audio software ( synths and and tools ) to a new Mac Mini 2018. My preferred DAW ( DigitalPerformer 9.52) , Native Instrument (Komplete 11 Ultimate) and Spectrasonics ( Omnisphere ) work fine in MOJAVE (Mac Mini 2018 ) but Numerology Pro 179 do not . ;-(
I just updated my main dev box to Mojave, and the new XCode. There are a few things to sort out w/ the new Xcode, hopefully not too timeconsuming...

Jim
Reply With Quote
  #25  
Old 01-19-2019, 07:17 AM
PLaine PLaine is offline
Member
 
Join Date: May 2013
Location: Finland
Posts: 98
Default

Quote:
Originally Posted by jim View Post
That sounds like an issue w/ MIDI Timestamping in OS X. Can you use the MIDIMonitor to run a trace on output from Numerology to the Mio4?

Jim
I have MIDIMonitor and I am used to check MIDI activity with it, but what exactly should try check in this particular case?

P.S. Yesterday I had quite many Numerology crashes with a project which in El Capitan worked without crashes.
Reply With Quote
  #26  
Old 04-28-2019, 09:15 AM
PLaine PLaine is offline
Member
 
Join Date: May 2013
Location: Finland
Posts: 98
Default

Hi,

I just remembered that I never got an answer to this question about new MIDI timing issues. I don’t know how much it is about new Mac OS (I have High Sierra) or Numerology bug, but here’s again what is much more common nowadays in my setup: when I hit play it’s typical that sequences start with MIDI mess, 0-2 seconds of loosing precise timing. Also it’s more common to have crash on same moment. I use hardware synths via iConnect mio4 interface.

Any idea how to fix this?

EDIT: At the moment there's a fix of putting few silent bars in the beginning of song but of course it would be nice to have it more solid in general. (Especially because this was working better earlier...)

Last edited by PLaine; 05-01-2019 at 06:03 AM.
Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -6. The time now is 07:54 AM.


Powered by vBulletin® Version 3.8.1
Copyright ©2000 - 2019, Jelsoft Enterprises Ltd.